Back to overview
Go.NUG and Go.NUG Admin are down
Apr 12, 2024 at 3:47pm UTC
Affected services
Go.NUG
Go.NUG Admin
Resolved
Apr 18, 2024 at 7:12pm UTC
All of NUG's websites and emails have returned to their normal state.
Affected services
Updated
Apr 12, 2024 at 4:02pm UTC
Go.NUG back to normal state.
Affected services
Created
Apr 12, 2024 at 3:47pm UTC
Go.NUG Admin back to normal state.
Affected services